Home > Discussion Groups > General

Message posting guidelines:

  • Full real names must be used at all times.

  • A valid e-mail address must be provided. (This is not optional)

  • Images must be posted at low resolution (72 dpi) and no larger than 760 pixels wide, and copyright/trade mark owners must be credited whenever reasonably possible.

  • Registration is compulsory if you wish to post messages on the Discussion Groups. For further information, please see the following message: http://www.network54.com/Forum/message?forumid=47207&messageid=1113822984

Please read our Community guidelines before posting.

By contributing to this discussion group, you indicate your agreement to the Terms and Conditions of Use.

Posts that violate the guidelines or Terms and conditions of Use of the Missing-lynx.com discussion groups will be erased, and repeated violation of this policy may result in termination of the violator's account.

Advertisement

 Return to Index  

Iwata airbrush

March 11 2017 at 10:00 PM
Doug Bauer  (Login drop-off)
Missing-Lynx members
from IP address 98.232.182.115

I broke down and bought an Iwata HP-C Plus airbrush, but have had nothing but problems with it: clogging (even with highly-diluted enamel/acrylics), spitting, very-low flow, etc. Is this operator error or something wrong with the unit? Any advice will be appreciated. TIA

 
 Respond to this message   
Responses

  1. It could be... - Frank Michaels on Mar 12, 2017, 9:34 AM
  2.  
  3. Too many possible variables... - Mike Roof on Mar 12, 2017, 12:04 PM
    1. Thanks for your valuable input, guys. n/t - Doug Bauer on Mar 12, 2017, 3:44 PM
     
  4. I use Iwata brushes - David Nickels on Mar 12, 2017, 6:28 PM
  5.  
  6. Call Coast Airbrush - Joe Bevans on Mar 12, 2017, 11:18 PM
  7.  


Terms and Conditions of Use
Report abuse