Respond to this messageReturn to Index
Original Message
  • I am so sorry for your losses (success mentioned)
    • thesameboat (no login)
      Posted Aug 27, 2012 10:54 PM

      I know how frustrating it is to go through cycle after cycle. It sounds like your RE is already aware of and supportive of treating immune issues. You wrote that you were on prednisone and heparin but not how much or for how long.

      5 mg prednisone didn't do anything for me. I had to start early and take 15 mg and I had to take that until 12 weeks before slowly weaning off. And the heparin I am on until the end. I was under the care of a reproductive immunologist after undergoing several DE cycles with no bfp. I finally got pregnant with donor 4 (5th transfer) but m/c. She then added a few extras. I am on OTC bovine colostrum pills every morning (1.5 mg on an empty stomach with about 10 oz of water), and took granocyte injections (one 2 hours before transfer and one 24 hours after). Also, because I tested positive for 2 copies of MTHFR I have to take very large doses of folic acid with B6 and B12. That reduces the homocysteine levels in my blood. Fish oil every day helps a little bit, too.

      The reproductive immunologist also did a BLOOD test to check for antibodies to chlamydia. I had only ever had vaginal swabs for that (and many, over the years) and I was shocked to find that the blood test showed that I have antibodies. She suspected the chlamydia lives too far up for the swabs to catch. So I take broadband antibiotics starting 3 days before transfer and continue for 3 days after transfer.

      I've had 2 transfers since that m/c and both were successful. I am a believer.

      I hope you find your answers soon. I know it hurts.
    Login Status
  • You are not logged in
    • Login
      Password
       

      Optional
      Provides additional benefits such as notifications, signatures, and user authentication.


      Create Account
    Your Name
    Message Title
    Message Text
    Image Services Photobucket.com
    Options
    Enable formatted text (what's this?)