<< Previous Topic | Next Topic >>Return to Index  

HELP!! I screwed something up!

June 27 2012 at 6:25 PM
Brian Gipperich  (Login Gipper49)
YF

Got my Chrony today and was playing with some settings on my new M-rod. I ran the striker all the way in clockwise until it seemed to just spin. Well when I went to fire the rifle, nothing. The hammer is moving forward but the valve is not opening. I THINK what I managed to do was run the striker clear out of the threads. My plan was to degas the rifle and take it apart and walk away with a lesson learned. The problem is I cannot degas the rifle as something (I assume the striker) is blocking the tool from opening the valve. My question is is it safe to disassemble the rifle with the air tube charged? Is there another way I can degas the rifle? I am running it on Co2 at the moment. Any help would be much appreciated.

Gipper (Brian)

 
 Respond to this message   
AuthorReply

Jeff P
(Login pad617)
YFOT

I think you'll be ok...

June 27 2012, 6:33 PM 

As long as you're just taking the breech and barrel and rear plug off to see what happened to the striker pin you'll be ok.

Jeff P

 
 Respond to this message   
Brian Gipperich
(Login Gipper49)
YF

Thanks...got it fixed NT

June 27 2012, 8:24 PM 


 
 Respond to this message   
 
  << Previous Topic | Next Topic >>Return to Index  

D I S C L A I M E R
JK's Airgun Forums, moderators, and administrators are not responsible for any problems that may occur from reading or using content posted on this forum, as they are the exclusive responsibility of two parties: the person who posted it and the person who acted on said posted information.Use of our forums from people under 18 years old, only with legal guardian(s) present.