This Essbase discussion board is provided as a free service and dedicated to all the Essbase professionals out there!
 


  << Previous Topic | Next Topic >>Return to Index  

Granting Essbase Server access to an user using Maxl or Esscmd

November 30 2011 at 8:46 AM
No score for this post
 
from IP address 198.203.224.219

 
Hi All,

Could any one of you please let me know how to grant an user to access the Essbase Server using Maxl or Esscmd.
I could find only no_access or adminstrator to grant. But how can we grant to access the server.

It would be appreciated if you suggest me ASAP.

Thanks in Advance.

Kumar

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
AuthorReply
Cameron Lackpour

71.162.226.73

grant has lots of roles

No score for this post
November 30 2011, 8:57 AM 

From a quick read of the Tech Ref, I see:
administrator
application manager
read
write
database manager
filter
calc

Are you using Shared Services? I have to say that I don't use MaxL to grant permissions/roles, but I'm sure someone on this board has and can comment on whether the two work together. I kind of think they do, but again, have not done it.

Regards,

Cameron Lackpour

 
Scoring disabled. You must be logged in to score posts.Respond to this message   



199.198.251.108

Re: grant has lots of roles

No score for this post
November 30 2011, 4:39 PM 

Use the CREATE USER command. Once the user is created, the user automatically has access to the server.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
Kumar

198.203.224.222

Not Creating Users

No score for this post
December 2 2011, 7:17 AM 

Hi,

We have Users defined in the Shared Services and are available here at Essbase after refreshing.

My question is instead of giving server access to the user at Shared Services manually, can we give it by Maxl or Esscmd.

One more thing, how can I give the Application access to a user through Maxl. i.e., A user should just access the Application and he should have just 'read' access on only one of the Databases in that application.

If I just give 'read' access to only one Database, is he able to access the Application it resides in directly without giving application access to him seperately. Or do I need to give first the application access and then read access to the database.

I hope there must be some solution, but I am not to that point. Please any one suggest me in this regard.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   



72.0.210.44

Re: Not Creating Users

No score for this post
December 2 2011, 7:23 AM 

You need to "create" the user on the Essbase server for that user to have access. So use the CREATE USER command.

When using Shared Services with your Essbase server, you cannot define database-specific access. That is, if you provide Read access to DB1 in APP1, the user will also have Read access to DB2 and DB3 (if they exist in APP1).

Use the GRANT command in MAXL to grant Read access to one of your users and read the warning that comes up.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   


198.203.224.222

Thanks...

No score for this post
December 2 2011, 7:47 AM 

Appreciate your quick reply Javier. Thanks.

Yes, you are correct. I am getting the warning like it will have access to other DBs in that Application.

So, if a user should have access to only one DB, we should use the CREATE USER statement on that DB. Is that correct. Is there no other way?

Also, if I use only CREATE USER statement on a DB, will an user have access to the Application automatically. Or do we need to explicitly give access to the Application first and then use the CREATE USER on DB.

Please suggest me in this regard.

Thanks & Regards
Kumar

 
Scoring disabled. You must be logged in to score posts.Respond to this message   



209.226.201.250

Re: Thanks...

No score for this post
December 2 2011, 7:52 AM 

Use the create user command to grant access to the Essbase *server*.

Use the grant command to grant access rights to the database. Please READ the warning.

Consider reading the documentation.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
Cameron Lackpour

74.109.33.166

This is a Shared Services "feature"

No score for this post
December 2 2011, 7:49 AM 

>>When using Shared Services with your Essbase server, you cannot define database-specific access. That is, if you provide Read access to DB1 in APP1, the user will also have Read access to DB2 and DB3 (if they exist in APP1).
^^^I find it really annoying as Essbase security (at least for BSO) has always gone down to a database level, at least until Essbase was hooked up to Shared Services.

Maybe Oracle just wants us to follow good practice and give each database its own application?

In any case this isn't tied to creating users in MaxL but again is how Shared Services security works -- you'll get the same result by doing it there.

Regards,

Cameron Lackpour

 
Scoring disabled. You must be logged in to score posts.Respond to this message   


198.203.224.222

Thanks...

No score for this post
December 2 2011, 8:00 AM 

Thanks for your reply Cameron.

Yeah, I agree with your words.

Anyways, I will follow your suggestions and give the security.

Thanks & Regards
Kumar

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
Current Topic - Granting Essbase Server access to an user using Maxl or Esscmd
  << Previous Topic | Next Topic >>Return to Index  
 Copyright © 1999-2014 Network54. All rights reserved.   Terms of Use   Privacy Statement  

RSS feed for this forum - http://www.network54.com/Forum/58296?xml=rss. Please email hypess (at) gmail.com, if you have any questions/feedback/issues.