This Essbase discussion board is provided as a free service and dedicated to all the Essbase professionals out there!
  << Previous Topic | Next Topic >>Return to Index  

Slow Aggs in new 11.1.2.4 environment

January 11 2017 at 3:54 PM
No score for this post
JS 
from IP address 108.171.130.163

This is kind of a vague question I know, but here goes.

We are in the middle of an upgrade from 11.1.2.3.500 to 11.1.2.4 (w/ .013) patch. We have a few large cubes, one at almost 100 GB and one around 50GB. Both of these are actually planning applications. We have noticed that our aggregations are significantly slower in the new .4 environment than they were in .3 One cube has a daily calc takes roughly 15 minutes in .3 but is taking almost 45 in .4. The other cube has a very long nightly process that takes roughly 8 hours in .3 but is taking about 24 hours in .4.

All things being equal, outline, db settings, config file settings, etc…I can’t understand why this is so much different. The new hardware is “supposed” to be better.

Has anyone run across this issue? Any ideas on what else I can check other than adjusting my cache settings for the billionth time?

Thanks.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
AuthorReply
Pete

146.178.41.11

Re: Slow Aggs in new 11.1.2.4 environment

No score for this post
January 11 2017, 9:00 PM 

Could it be parallel calculation \ essbase.cfg settings?

I'm guessing you've checked all that already though.

That's a massive change to be explained by hardware (in either direction)

Raised an SR?

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
JS

108.171.130.163

Re: Slow Aggs in new 11.1.2.4 environment

No score for this post
January 11 2017, 9:30 PM 

Yeah, I submitted and SR yesterday.

There's just a lot of inconsistency. I have an allocation script that I ran manually multiple times today and it took about 20 minutes each time. That same script is run as part of a sequence that I kicked off and it took over 2 hours. I ran it again this evening and it took an hour.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   

er77

194.67.28.146

Re: Slow Aggs in new 11.1.2.4 environment

No score for this post
January 12 2017, 6:21 AM 

latest essbase work diferently in parallel calcualtion (if u use calcparallel ) .
Now u need to move up "non agg" dimension from bottom outline

 
Scoring disabled. You must be logged in to score posts.Respond to this message   

Javier

173.180.74.50

Re: Slow Aggs in new 11.1.2.4 environment

No score for this post
January 12 2017, 9:06 AM 

Are you running them as business rules? I wonder if you are hitting a timeout setting that is causing the business rules to be re-launched?

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
JS

108.171.130.163

Re: Slow Aggs in new 11.1.2.4 environment

No score for this post
January 12 2017, 11:25 AM 

Javier - Yes I am running them as business rules. If I hit a timeout, would that be logged somewhere? One thing I thought may have been an issue is running the individual rule vs running a ruleset. When I ran the rule individually (from Business rules in Planning) it was running pretty consistently around 20 minutes. When I execute a sequence which calls a ruleset that includes that rule, it was taking longer. But last night I ran the individual rule again and it took over an hour.

ER - that's interesting and I'm testing that now. I have updated my outline to a traditional hourglass, related the data and agg'd. I'm rerunning the calc now which has been running for 40 minutes or so. I will have to do some additional testing with new calc parallel and calctaskdims settings based on thew new outline structure.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   

Javier

142.58.28.57

Re: Slow Aggs in new 11.1.2.4 environment

No score for this post
January 12 2017, 12:09 PM 

Check the Job Console. If you see your BR listed multiple times (with runs that are yours but aren't) that's probably it.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   

Gary Crisci

104.129.194.69

Re: Slow Aggs in new 11.1.2.4 environment

No score for this post
January 12 2017, 12:58 PM 

There were architectural changes between 11.1.2.3.500 and 11.1.2.4 that made cube performance change. We had to go back and retune most of our apps. In some cases we had to change Stored and Dynamic dimension settings. Where in the past stored was always better, we found a few cases where a dimension as dynamic was better. You may need to play around with them a bit. Ultimately we got better performance when tuning was complete, but lift and shift was not going to work.

 
Scoring disabled. You must be logged in to score posts.Respond to this message   
 
  << Previous Topic | Next Topic >>Return to Index  

RSS feed for this forum - http://www.network54.com/Forum/58296?xml=rss. Please email hypess (at) gmail.com, if you have any questions/feedback/issues.