i do want to add this to what i saidby mennonite (no login)
i like the idea of _roundnum() a lot, and it's being offered to you as a favor, but i don't think you need to include it.
if int() works as you say it will (qb compatible) i will be happy. i mention _roundnum() because you're trying to figure out an improved statement. i'm trying to help you do it. the statements you add should be for now at least, up to you i think. _roundnum() is your option, and if you "mess it up" i can call it something else if i want it in another basic language, no worries.