I didn't use the modified code

by qbguy (no login)

 

I downloaded the VANILLA qb64 zip file from the qb64 website.

I install Ubuntu 8.04 Hardy Heron in a dual boot on my laptop.

I installed wine on Ubuntu.

I ran compile.exe in wine. It translated the BASIC code to C++, said "C++ code compiling" and opened a console window (which I guess is gpp.exe running in wine).

It said C++ compilation succeeded. I ran diamond.exe and it worked.

I then opened qbx.cpp. I saw that msbin.cpp was in lowercase letters even though the file is actually MSBIN.CPP (Linux is case sensitive). I also noticed that direct.h was used (which didn't work when I tried to compile with Linux g++) and that __int8 was used. So Galleon had not added my Linux compatibility patches.

So there must have been some sort of update to wine that allowed the mingw g++ to run.


Posted on Jul 9, 2008, 6:20 PM

Respond to this message   

Return to Index

Response TitleAuthor and Date
i'll just have to wait until dsl can run 1.0 thenmennonite on Jul 9
 just a reminder that qbguy is awesomemennonite on Jul 18

 Copyright © 1999-2014 Network54. All rights reserved.   Terms of Use   Privacy Statement