Problem with Shell running batch file

by glg (no login)


EDIT - Problem solved!
I just had to rename mediainfo.exe to mediainf.exe

(glg posted the above to an otherwise duplicate post on Mar 21, 2012, 3:46 PM. --- mc)

I am trying to use mediainfo.exe along with mediainfo.dll in QBASIC

I am having a problem running the Sell command

I have a batch file -> mymedia.bat:

mediainfo.exe --Inform=file://template.txt video.mp4 >> new2.txt


If I just run the batch file from a dos prompt - it works as it should

If I run the Shell command then type in mediainfo.exe --Inform=file://template.txt video.mp4 >> new2.txt - it works

If I run the Shell command then type mymedia.bat - it works

But when I try to run the batch file from the Shell:
m$ = "mymedia.bat"

the output is:

C:\QBASIC>mediainfo.exe --Inform=file://template.txt video.mp4 >> new2.txt

Bad command or file name

I have no problem running a batch file for ffmpeg.exe or gm.exe [graphicsmagick}

I have in my QBasic folder
MediaInfo.dll version
MediaInfo.exe [MediaInfo Command Line Interface] version

Any help would be appreciated

This message has been edited by MCalkins on Mar 24, 2012 4:57 AM

Posted on Mar 21, 2012, 3:32 PM

Respond to this message   

Return to Index

Response TitleAuthor and Date
Re: Problem with Shell running batch fileMercury on Mar 21

 Copyright © 1999-2015 Network54. All rights reserved.   Terms of Use   Privacy Statement